Función CONTAR.SI de Excel

Comparte esto

La función CONTAR.SI de Excel cuenta los valores de un rango que cumplen el criterio especificado en los argumentos.

La función CONTAR.SI(rango, criterio) tiene dos argumentos obligatorios (rango y criterio).

  • rango es el rango donde se van evaluar los criterios especificados en el siguiente argumento.
  • criterio es el criterio que tiene que cumplir los valores que se van a contar, si el criterio incluye algo más que números hay que escribirlo entre comillas dobles. Puedes utilizar comodines como * y ?:

El siguiente ejemplo cuenta los valores mayores que 10

=CONTAR.SI(A2:A7;»>10″)

Función contar.si de Excel

A continuación tienes unos ejemplos de la función CONTAR.SI obtenidos de la web de Microsoft.

DatosDatos
manzanas32
naranjas54
melocotones75
manzanas86
FórmulaDescripción
=CONTAR.SI(A2:A5;»manzanas»)Cuenta el número de celdas con manzanas entre las celdas A2 y A5. El resultado es 2.
=CONTAR.SI(A2:A5;A4)Cuenta el número de celdas con melocotones, el valor de A4, entre las celdas A2 y A5. El resultado es 1.
=CONTAR.SI(A2:A5,A2)+CONTAR.SI(A2:A5,A3)Cuenta el número de manzanas, el valor de A2, y de naranjas, el valor de A3, entre las celdas A2 y A5. El resultado es 3. Esta fórmula usa CONTAR.SI dos veces para especificar varios criterios, un criterio por expresión.
=CONTAR.SI(B2:B5;»>55″)Cuenta el número de celdas con un valor superior a 55 entre las celdas B2 y B5. El resultado es 2.
=CONTAR.SI(B2:B5;»<>»&B4)Cuenta el número de celdas con un valor distinto de 75 entre las celdas B2 y B5. El símbolo de la «y» (&) combina el operador de comparación «<>» (no es igual a) y el valor de B4 para leer =CONTAR.SI(B2:B5,»<>75″). El resultado es 3.
=CONTAR.SI(B2:B5;»>=32″)-CONTAR.SI(B2:B5;»>85″)Cuenta el número de celdas con un valor superior o igual a 32 e inferior o igual a 85 entre las celdas B2 y A5. El resultado es 3.
=CONTAR.SI(A2:A5,»*»)Cuenta el número de celdas que contienen texto entre las celdas A2 y A5. El carácter comodín * se usa para reemplazar cualquier carácter. El resultado es 4.
=CONTAR.SI(A2:A5,»?????es»)Cuenta el número de celdas que tienen exactamente 7 caracteres y que terminan con las letras «es» entre las celdas A2 y A5. El signo de interrogación (?) se usa como carácter comodín para coincidir con caracteres individuales. El resultado es 2.

Más información sobre la Función CONTAR.SI de Excel

Puedes consultar más información en la web de Microsoft.

Si te ha gustado puedes consultar otras entradas de Excel o de Office.

También puedes consultar nuestros cursos de Office con los que aprendes a manejar con soltura Microsoft Word.

Finalmente puedes solicitar más información a través de:

También en el siguiente formulario.


Comparte esto